Error for Metro and other themes.

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Error for Metro and other themes.

This topic contains 9 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 7 years, 6 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #3145
    Jesse Hancock
    Jesse Hancock
    Participant

    It works fine for Default and Metro theme but most of the other themes produce the following error:

    Error while parsing PHP: syntax error, unexpected ‘version’ (T_STRING)
    Kind Regards,
    Jesse

    • This topic was modified 7 years, 6 months ago by Jesse Hancock Jesse Hancock.
    #3153
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Do you see this on the preview box or on the frontend after saving the options?

    May I have a look at this? Based on the error message I can’t tell where it’s originated from.
    You can provide temporary admin details if you edit your initial post.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #3166
    Jesse Hancock
    Jesse Hancock
    Participant

    Hi there,
    Thanks for your reply, you can see the error here:
    http://shopmenu.com.au/wp5/

    Underneath the widget bar on the right. I’m using the headway theme.
    I now cant get it to display at all, regardless of the theme. They do display correctly in the backend.

    I would provide you with login details but I can’t get your private box above to work.
    Cheers,
    Jesse

    #3167
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I see. Well, there are no other hidden error there, so I don’t know yet.

    You can edit your inital (first) post and fill them in there. Or you can just simply attach a txt file to your next reply with the details. It remains private – visible only for you and me.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #3185
    Jesse Hancock
    Jesse Hancock
    Participant

    I’ve edited my first post to include login details.
    Cheers,
    Jesse

    #3195
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Could you please check the details, I can’t seem to be able to log in.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #3204
    Jesse Hancock
    Jesse Hancock
    Participant

    Sorry about that, I’ve re-opened that account. Let me know how you go.
    Cheers,
    Jesse

    #3207
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I’ve enabled the plugin and it’s working fine right now when I add it to the sidebar: https://i.imgur.com/sCP5Qm2.png

    Your purchase code shows me a purchase date and time Sun Dec 07 22:00:13 +1100 2014 which is not corresponding with the search version you use. Your site has plugin version 3.1 installed, which should not be available from 7th of october. On 7th of december you should have gotten version 3.5.

    In case you are using a 3rd party pirated version, please completely delete it, it’s very dangerous. 3.1 is a well known pirated copy and most of the free pirated downloads can contain malicious code, which steals your server credentials, like mysql passwords, admin passwords, corrupts the file system and installs backdoors to your wordpress installs. If that’s not the case, then my apologies.

    Either way, please upgrade to version 3.5 which should be available on codecanyon if you download the plugin. An bugfixed version was uploaded just yesterday. The documentation contains information about how to upgrade, which you can find here: http://wp-dreams.com/demo/wp-ajax-search-pro3/docs/#important_upgrade_notes

    Let me know if you still experience the issues after the upgrade.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #3213
    Jesse Hancock
    Jesse Hancock
    Participant

    Thanks for your detailed reply. I followed all your instructions and this resolved a lot of my issues, however I’m still having a problem when i use some of the themes in a fresh install that removes any nulled scripts see link below.

    I’ve upgraded to 3.5, but when I use the “Fatty RL Vintage out of space” theme it displays the same error.
    “Error while parsing PHP: syntax error, unexpected ‘version’ (T_STRING)”

    http://shopmenu.com.au/wp10/
    You can access this using the same username and password as before.

    #3214
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I tried the theme editor and the “Custom code” block was generating the issue. I switched it to simple text and put the shorcode there, and it’s showing now.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.