Filters Not Refining Search Based On -And- Logic

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Filters Not Refining Search Based On -And- Logic

This topic contains 1 reply, has 2 voices, and was last updated by

3 years, 5 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #18891


    Below is my chat on ThemeForest

    SevereTech Purchased Supported
    1 day ago Flag

    How to use filters to refine search? I don’t need any other results to show if they aren’t in category.

    You can test my NFL Draft Prospects filter on home page of our website You can test my player profile by selecting a category below…

    01.) Draft Class 02.) Positions 03.) College Teams 2019 Akron OG Profile

    wpdreams Author
    about 17 hours ago Flag


    I believe this is the option you are looking for. When disabled, items not assigned to any of the filter categories will be excluded automatically.

    Best regards,
    Ernest Marcinko

    SevereTech Purchased Supported
    about 14 hours ago Flag

    I very much appreciate your reply. When I try the option you suggest, no results return. I haven’t tried this but it’s almost as if logic behavior is every category must be selected first before item appears. That’s if I change setting to what you suggested. Are there other variables that affect the ‘and’ logic behavior for filter selections.

    You must be logged in to view attached files.


    The taxonomy ‘and’ logic only applies if you have multiple taxonomy filters (terms from multiple taxonomies). For each taxonomy, the Category/Taxonomy terms logic is applied.

    By default, all of the selections must match the result, as well as the unchecked are treated as exclusions. For most cases this is fine, however in your case I believe the At least one of the selected terms should match option will be much better.

    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.