Is there a way to display taxonomy fields before custom fields?

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Is there a way to display taxonomy fields before custom fields?

This topic contains 7 replies, has 2 voices, and was last updated by

 
Keymaster
3 years, 5 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #18769

    Participant

    Hello, as the title says I’m wondering if there’s a way to display the taxonomy fields before the custom fields in a search bar since I didn’t find a related setting in the plugin’s configuration
    Also, I was wondering if there’s a way to setup a default option in the custom fields like the one in the taxonomy fields.
    Thanks.

    #18771

    Hi!

    Yes, you can change the ordering under the Frontend Search Settings -> Advanced panel, right here: https://i.imgur.com/kbDW4vQ.png

    The default option in custom field filters is the one that has the double stars at the end of line **. For example, in this case, sample_value2 is the default value. For more details, you can check the documentation here.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #18779

    Participant

    Thank you very much, that worked.
    Now I have a bug when there’s not a match in the search, the search field gets duplicated and I’m not sure why. I attached a screenshot of the issue, I hope you can help me with this.
    Thanks again for the help.

    Attachments:
    You must be logged in to view attached files.
    #18785
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #18801

    Participant
    You cannot access this content.
    #18805

    Hi,

    Thank you very much. Can you please copy/paste the shortcode you are using there exactly? I think there might be a problem with that, I am not sure. It looks like it is only a minor visual issue though.

    Also, this custom css should get rid off the problem permanently:

    .asp_sb_2_2 {
       display: none !important;
    }

    Thank you!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #18835

    Participant

    Hello,
    Thanks for the fix, it does hide the second bar.
    Here is the shortcode I’m using in the website:

     [wd_asp elements='search,settings' ratio='20%,80%' id=2] 

    Thank you again for the help!

    #18841
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.