Isotopic Results > Display animation not working

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Isotopic Results > Display animation not working

This topic contains 11 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 5 years, 7 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #11023
    Manu
    Manu
    Participant

    Hello,

    It’s seems i can’t change the animation for the results when i’m changing page.

    My settings :
    Layouts options > Results layout > Results layout type > “Isotopic Results”

    Theme options > Isotopic Results > Display animation > don’t have any effect.

    Advanced options > Animation > Result items animation > work perfectly for the first apparition of the results.

    Thank you for your help !

    #11031
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    I’ve tried to re-create the problem on my test environment, but it works correctly. If you have any type of cache or minification enabled, make sure to clear them all: CDN, browser cache, page cache, static content cache, minify cache etc..
    The animations are generated to the CSS file, and if it’s cached, then it might not have an effect immediately.

    If nothing helps, then can you please add temporary FTP and back-end details, so I can check the issue directly?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #11040
    Manu
    Manu
    Participant

    Thanks for your fast anwser,
    Ok I’m going to try what you said and i will let you know.

    #11041
    Manu
    Manu
    Participant

    Can you give me the name of the css files impacted by the change ?

    Thank you,

    #11042
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    It’s either the

    /wp-content/uploads/asp_upload/style.instances.css

    ..or depending on your configuration there might be individual CSS files per instace in that same folder marked with the search instance ID, so:

    /wp-content/uploads/asp_upload/searchX.css

    where X is the instance ID. However it’s most likely the first one, as that is the default loading method.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #11044
    Manu
    Manu
    Participant

    Thank you,

    When i change Theme options > Isotopic Results > Display animation >

    I can see that the date of the file /wp-content/uploads/asp_upload/style.instances.css is updated.

    However if i change the setting lightspeedout to something else like rotatein, even if the date of the file is updated the code is strictly identical (looking directly on the server throught ssh).

    If i change the result box backgound color on the same setting page it’s working.

    I’ve desactivated all the cache / cdn etc ..

    Thank you for your help,

    #11045
    Manu
    Manu
    Participant

    NB : searchX.css are not updated when i change the animation setting. (Theme options > Isotopic Results > Display animation )

    #11046
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Do the options change on the back-end, or do they revert back to the default values?

    If they revert back, then there is a good chance that there might be a server limitation to the POST method variables. By default is should be 3000, which is plenty enough, but some hosts decide to lower that. In that case you can try to put the following code in the .htaccess file in the root web directory:

    php_value max_input_vars 3000

    Then change and save the options again. This might not have any effect at all, some servers only allow changing the max_input_vars directive via php.ini.

    If this is not the case I will have to see it to be able to tell what is happening.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #11047
    Manu
    Manu
    Participant

    Hi Ernerst,

    Nop the options are reverting back to the default values.
    What is strange is that the result box backgound color is working.
    I tried to play with the minification coming with your plugin but stull no luck. Same when i’m forcing inline-style.
    I’m not having anything inside the log.
    For info I’m using PHP7, Nginx, MariaDB

    Thank you,

    #11048
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    In that case it’s almost definitely the max_input_vars is set to a lower value than the default 3000.

    Since with nginx you don’t have a .htaccess file, you will have to look for that in the active php.ini file. If it’s not in there, just put this line there:

    max_input_vars = 3000

    Then restart nginx and php-fpm or mod-php or whichever one you are using and it should start working.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #11049
    Manu
    Manu
    Participant
    You cannot access this content.
    #11051
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    No idea then. Without seeing the issue, I can only guess. This still can be a conflict of some sort, or if the data is posted correctly but not stored correctly.

    If you want, you can update your ticket with temporary FTP and back-end access and I will try to debug through the code to see where it fails.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.