No Drop-down and filter taxonomies are working

Home Forums Product Support Forums Ajax Search Pro for WordPress Support No Drop-down and filter taxonomies are working

This topic contains 3 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 3 years, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #19668
    Louay
    Louay
    Participant

    Hello,
    Many thanks for your good plugin. I would like to inform you that I have three major issues with your plugin at the moment.
    First, In the main search bar that appears in the homepage, the drop-down button does not appear, so the user can’t choose any filters or taxonomies.
    Second, the filters on the widgets areas are not working. No matter what taxonomy is used, the same results are shown.
    Third, with some certain keyboard that exists in some articles and courses, the site keeps spinning and no results are shown. For example, the word “read”.
    I have tried my best to fix problems, but I couldn’t.

    I would like to note that I don’t have coding knowledge and I would really appreciate it if you could fix the issues that I’m having. Many thanks in advance

    Kind regards,
    Louay

    #19677
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Louay,

    Thank you for the proper details, it helps me a lot!

    1. Make sure that the swith is enabled, otherwise it will not be displayed, you can enable it here: https://i.imgur.com/RgYBtJC.png

    2. I assume, that results, that does not belong to any of the filtered taxonomies are displayed. This is the default behaviour, but in some cases this is not the expected behaviour. To turn off results, that does not belong to any of the category filters, you can turn off this option. It will make sure, that only items related to the filters are displayed.

    You can also experiment with these options and combinations, to get the best possible configuration to your needs.

    3. I tried the “read” keyword on both instances, but I am seeing results right now. It might have been only a temporary server or connection issue, it should be fine now.

    I hope this helps!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #19746
    Louay
    Louay
    Participant

    Hello
    Many thanks for your kind reply and for the certification. I’m still working on the options you have provided to have the required behaviour. Are there any other ways to have more accurate results and to only get the results of the selected filters? It seems the written keywords in the search has more priority on the selected filters and this it shows results from other filters even if not selected.
    I would also inquire about the design of the drop-down on the main search bar (home page). All the filter are arranged vertically and it’s quite long as you can see in the image attached. How can rearrange the filter horizontally as it’s shown in the demo in your website?
    Many thanks for your kind answer.
    Best,
    Louay

    Attachments:
    You must be logged in to view attached files.
    #19760
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Louay,

    The filters actually do work in combination with the keyword, so they are active regardless what the keyword is. If you start the filters as unselected, then maybe trying out this logic could lead to more desired results.

    You can change the number of columns here, to have a better layout there.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.