Not finding the page with input keyword

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Not finding the page with input keyword

This topic contains 5 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 year ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #33079
    reno.verdi08
    reno.verdi08
    Participant

    Hi Ernest,

    so we implemented the search plugin as on this page:
    https://www.ooma.com/

    Click the magnify and type ‘real estate’ … we expect below page suppose to show (due to may matching words in the content or post title, which is Business phone service for real estate companies.) but somehow it is not there in the list.
    https://www.ooma.com/business-phone-service/real-estate-companies/

    We are not allowed to share login information to outside vendor/company, I could however send you search instances via export. Could you help troubleshoot? We do not use any crazy configuration:
    – search in post, pages.
    – primary keyword login: AND exact matches then OR (only).
    – some category exclusion but this page does not fall under excluded category.
    – no front end search setting tweaked except add hidden field to exclude page without index ( postmeta _yoast_wpseo_meta-robots-noindex NOT EQUALS 1) — but even if I remove this setting the real estate page is still not showing.
    – no index table is used just generic engine.
    – no prioriries used (default).

    Let me know if you need additional info, otherwise please advise and thanks in advance.

    #33081
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    The exports may not help, as I won’t be able to see everything in it. First, try to create a new search instance, and leave the configuration as it is. Then try searching for that page by it’s exact title to see if it shows up. Let me know.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #33088
    reno.verdi08
    reno.verdi08
    Participant

    Found the issue, I think the hidden field setting is the culprit _yoast_wpseo_meta-robots-noindex NOT EQUALS 1.
    When I dropped this configuration the post shows up.

    I set this up on Frontend Search Settings > Custom Field > _yoast_wpseo_meta-robots-noindex (Post meta) NOT EQUALS 1
    with the hope that all non indexed post/page will not show up on search.

    Is the search using some sort of inner join, that if the post does not have this meta will not get included (post that is indexed will not have this meta _yoast_wpseo_meta-robots-noindex=1). I am not sure why having this config restrict that real estate post to show up.

    Please advise.

    #33093
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Try enabling this option: https://i.imgur.com/eEZKuvp.png
    With that, the custom field restriction should not extend to items, which does not have that field.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #33106
    reno.verdi08
    reno.verdi08
    Participant

    Fantastic, Thanks! That works!

    Another question, still same keyword to make it easier:
    https://www.ooma.com/ Searching “Real Estate”
    https://www.ooma.com/business-internet/continuous-voice/ this page, and some other similar page shows up
    – the problem with this is that the word “real estate” is somewhat hidden ( it is located in the marketo form that we have under Download brochure section) Click Download button – form pop up shows up – there is field for industry select dropdown, which ‘Real Estate’ keyword resides.
    – So technically the search inside content works but it is less accurate since keyword only reside in the lead form, not in any other main content.
    – Is there a way to get around this to increase relevance? Please advise.

    Thanks

    #33114
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Do you mean not indexing those sections somehow so those does not show up when entering “real estate”? Well, if you are using the index table engine, and that section is printed via a shortcode – then you can add that shortcode to the exceptions list: https://i.imgur.com/KohIAuo.png
    Other than that, you can also use the negative keywords input on the post editor screen: https://i.imgur.com/Dj0NnRl.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.