Pagination Issue

This topic contains 5 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 6 months, 3 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #45028
    johnny
    johnny
    Participant

    Hi there,

    We’re experiencing an issue with the search results page.

    When trying to load more products through pagination we receive the following error: ‘This request has failed. Please check your connection.’

    Steps to reproduce the error:

    1. Click the search icon from the navigation menu.
    2. Type a search term and hit enter.
    3. On the search results page click the pagination link (page 2 for example).
    4. The page doesn’t load any more results and gives the error ‘This request has failed. Please check your connection.’

    Please advise and reply to [email protected]

    Kind regards,
    Johnny

    #45040
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Johnny,

    Thank you very much for the details!

    I logged in to quickly check, and the server reported a “too long URL” issue, which was caused by some unused filters. I have cleared these from the frontend search settings panel, and now those query parameteres are no longer present in the pagination link (it made it shorter).
    Now clicking on any of the pages should be all right.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #45043
    johnny
    johnny
    Participant

    Hi Ernest,

    Many thanks for the support! That has fixed the issue with the product search result pagination.

    It seems there is still an issue with the blog post search results though.

    Steps to reproduce the issue:

    1. Click the search icon from the navigation menu.
    2. Select the ‘News & Events’ tab.
    3. Type a search term and hit enter.
    4. On the search results page click the pagination ‘load more’ button.

    Any ideas?

    Kind regards,

    Johnny

    #45044
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Great!

    Oh I didn’t realize there was another search bar. In that case I see you are trying to make a custom results page via this tutorial.
    From the page source it seems that the element type is incorrect, make sure to use the Posts widget and not the Archive posts widget.
    I also advice agains using the “load more” feature if you notice any weirdness with it. Elementor may not be happy about trying to override the posts, however the pagination should still work just fine.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #45047
    johnny
    johnny
    Participant

    Many thanks Ernest. That solved the problem.

    I notice now on the product search results page that the ‘enter key’ or ‘magnifying glass’ icon doesn’t refresh the page. Seems as though the redirect trigger has stopped working?

    Thanks again for taking a look at this. Much appreciated.

    Kind regards,
    Johnny

    #45060
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    You are very welcome Johnny!

    I checked, and it was because of this option was enabled, at the same time as the elementor live loading – so the plugin could not figure out which element to live load, so it just stopped.
    I turned it off (as it is redundant), now it should be okay again.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.