Response data is missing from the ajax request when using Weglot multilanguage

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Response data is missing from the ajax request when using Weglot multilanguage

This topic contains 3 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 5 years, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #12808
    windkracht20
    windkracht20
    Participant

    Hi,

    I’m using you ajax search pro plugin on my site along with WeGlot for multilanguage. In the default language (Dutch) the search field is returning data allright. But when I select another language, I get a warning popup: The response data is missing from the ajax request.

    I used both index and non index search, but the same warning appears. Any idea?

    Best regards,
    Bjorn

    Attachments:
    You must be logged in to view attached files.
    #12810
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Bjorn,

    I’m not able to log-in, it requests a verification code, but I believe it’s sent to a different address: https://i.imgur.com/cNTODgL.png

    The problem is, that most likely the multi-language plugin is tempering with the response data within the ajax request, as it is returned incorrectly, and the search is not able to de-code it. The results are there, but there are missing and replaced characters within the response body, which causes the issue.

    There is not much to do about it from the search perspective, but there is one option you could try. On the Compatibility settings submenu, try enabling the Use the custom ajax handler option: https://i.imgur.com/Al9BzWy.png
    It is very likely that it won’t help, but it’s worth a try. In this case, there might be some kind of filter or something to exectute to make an exception for the translator, but you might have to ask the plugin author for that.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #12811
    windkracht20
    windkracht20
    Participant

    Hi Ernest,

    thank you for your very quick reply. Sorry about the two factor verification. I forgot that that was enabled for the account. However, the compatibilty switch did the trick (although the results are being shown in de default language instead of the target language, it’s way better than the error message ;-)) I’ll forward it to the developers of WeGlot so they might take it into account.

    Thanks a lot for your support and awesome plugin!
    Best regards,
    Bjorn

    #12812
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    You are very welcome, and thank you for your kind words!

    Let me know if they respond, and if there is anything I can do or implement to make the plugins compatible in the future. I’m very happy to do so.

    If you like the plugin, feel free to rate it on your codecanyon downloads page, it’s greatly appreciated.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.