Response Data Missing Error

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Response Data Missing Error

This topic contains 1 reply, has 2 voices, and was last updated by

 
Keymaster
1 year, 5 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #28792

    Participant

    Hi,
    Thanks in advance for any help provided.

    Went through all your steps mentioned on your site to do before creating request. Disabled plugins, default theme, etc., wp_debug displayed no relevant info.

    I’m receiving the following error when not logged in to WordPress, the search works fine when logged in as admin:
    Ajax Search Pro Warning: The response data is missing from the ajax request!
    This could mean a server related issue.

    Check your .htaccess configuration and try disabling all other plugins to see if the problem persists.

    The contents of my .htaccess file is below:
    # BEGIN WebP Express
    # The directives (lines) between
    BEGIN WebP Express and END WebP Express are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    # The rules below is a result of many parameters, including the following:
    #
    # WebP Express options:
    # - Redirection to existing webp: enabled
    # - Redirection to converter: enabled
    # - Redirection to converter to create missing webp files upon request for the webp: enabled
    # - Destination folder: mingled
    # - Destination extension: append
    # - Destination structure: doc-root
    # - Image types: jpeg, png
    #
    # WordPress/Server configuration:
    # - Document root availablity: Available and its "realpath" is available too. Can be used for structuring cache dir.
    #
    # .htaccess capability test results:
    # - mod_header working?: no
    # - pass variable from .htaccess to script through header working?: no
    # - pass variable from .htaccess to script through environment variable working?: no
    #
    # Role of the dir that this .htaccess is located in:
    # - Is this .htaccess in a dir containing source images?: yes
    # - Is this .htaccess in a dir containing webp images?: no

    # Rules for handling requests for source images
    # ---------------------------------------------

    <IfModule mod_rewrite.c>
    RewriteEngine On

    # Redirect to existing converted image in same dir (if browser supports webp)
    RewriteCond %{HTTP_ACCEPT} image/webp
    RewriteCond %{REQUEST_FILENAME}.webp -f
    RewriteRule ^/?(.*)\.(jpe?g|png)$ $1.$2.webp [NC,T=image/webp,E=EXISTING:1,L]

    # Redirect to existing converted image in cache-dir (if browser supports webp)
    RewriteCond %{HTTP_ACCEPT} image/webp
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteCond %{DOCUMENT_ROOT}/wp-content/webp-express/webp-images/doc-root/wp-content/plugins/$1.$2.webp -f
    RewriteRule ^/?(.+)\.(jpe?g|png)$ /wp-content/webp-express/webp-images/doc-root/wp-content/plugins/$1.$2.webp [NC,T=image/webp,E=EXISTING:1,L]

    # Redirect images to webp-on-demand.php (if browser supports webp)
    RewriteCond %{HTTP_ACCEPT} image/webp
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteRule ^/?(.+)\.(jpe?g|png)$ /wp-content/plugins/webp-express/wod/webp-on-demand.php?xsource-rel=xwp-content/plugins/$1.$2&wp-content=wp-content [NC,L]

    # Make sure that browsers which does not support webp also gets the Vary:Accept header
    # when requesting images that would be redirected to webp on browsers that does.
    <IfModule mod_headers.c>
    <FilesMatch "(?i)\.(jpe?g|png)$">
    Header append "Vary" "Accept"
    </FilesMatch>
    </IfModule>

    </IfModule>

    # END WebP Express

    Please let me know if you need me to provide any further information to diagnose this issue.

    Best,
    Donald

    #28794

    Hi Donald,

    The issue is, that the wordpress ajax handler URL is not correct. The plugin tries to do a request to the site main page, while it should be requesting the /wp-admin/admin-ajax.php file. I strongly recommend investigating that issue, the WordPress default ajax url should not be changed, it may conflict with other plugins as well. It is unfortunately not caused by the this plugin, because the search only requests that URL from the WordPress core.

    As a temporary resolution, you can enable the custom ajax handler here: https://i.imgur.com/ZFp7fv2.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.