Search in the whole title instead of only beginning

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search in the whole title instead of only beginning

This topic contains 4 replies, has 2 voices, and was last updated by gaspodex gaspodex 5 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #13555
    gaspodex
    gaspodex
    Participant

    Hello,

    We experience an issue with the search engine. There is no problem with the ajax search, but when the user presses enter to go to the results page (search.php), it searches only in the first word(s) of the title.

    For instance, we have a product called “Article 353 du code pénal”. When searching “article”, the product will appear in the ajax search and the search.php page. When searching “353”, the product will appear in the ajax search but not the search.php page.

    I didn’t find where I could set this in the plugin settings. Do you have any advise there ?

    Regards,

    Mr Camille Prioul

    #13557
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I see you have the search override enabled, so your settings are correct. The problem in this case is probably that something else is overriding the search results passed on by the Ajax Search Pro plugin to the search.php file.

    It can be another search plugin with a search override activated, or there is a direct code within the search.php file which runs a separate query, that ajax search pro is not able to override. Usually it’s the second one, and the only way to overcome that is to remove that unneccessary query from the search.php file, as the search results are already passed to it by WordPress core.

    If you want, you can leave FTP and back-end access, and I will take a look at the theme code via FTP to check if that is the case, and if it’s fixable at all.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #13560
    gaspodex
    gaspodex
    Participant
    You cannot access this content.
    #13561
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thanks for the details, I think I have found the problem. The results count was set to -1. That will not work, I have changed it back to the default 10: https://i.imgur.com/CHgoR4C.png

    Now it should display the same results as the live search.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #13563
    gaspodex
    gaspodex
    Participant

    Thanks !

    Alright, I see the problem.
    The thing is, I wanted to have all the results on the same page. Is there any way to have this without damaging the results ?

    Regards,

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.