Search not working on some phones

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search not working on some phones

This topic contains 6 replies, has 2 voices, and was last updated by Stratur Stratur 5 years, 9 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #10613
    Stratur
    Stratur
    Participant

    Hi.

    Awesome plugin this is. But search function started to not working on some phones: Galaxy A5, Windows lumina.

    Search bar just searching but no results appear.

    #10614
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thank you for your kind words!

    The problem is not actually with the phones, but with the server. It looks like your website is configured to the http://www.asitek.ee url, but it’s accessible without the “www” part as well. If you access the site without asitek.ee, the ajax requests are still sent to the http://www.asitek.ee url, which causes the problem, as it qualifies as a cross domain request, and it’s not allowed by your server.

    To solve it, make sure to set the server url to http://www.asitek.ee everywhere. You can also use a .htaccess rule in the .htaccess file in the root directory to force redirect all visitors to the “www” prefixed url:

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #10616
    Stratur
    Stratur
    Participant

    Hi.

    Thanks for fast response.

    But Url is with SSL so its https://www.asitek.ee/
    so should I change rewrite code to https instead?

    #10617
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I’m not sure if that is going to work, but yes, you should change that to https instead.

    Also, make sure that on the site settings the site url is set correctly.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #10618
    Stratur
    Stratur
    Participant

    Hi actually I have htaccess already like this

    RewriteEngine on
    RewriteCond %{HTTPS} !=on [NC]
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

    #10619
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I think you can still use that below these lines, they should not conflict.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #10621
    Stratur
    Stratur
    Participant

    Ok I think I got it now.

    I added your code and it worked, because it had (www) too.

    I will test it on other phones later, but it looks like issue is fixed.

    So thanks for fast and very helpful reply!

    PS! I have already 5 stared plugin on themeforest.

    Good luck and thanks!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.