search settings not displaying

Home Forums Product Support Forums Ajax Search Pro for WordPress Support search settings not displaying

This topic contains 5 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 year, 9 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #29968
    dangoren89
    dangoren89
    Participant

    Sorry to bother you again, but tearing my hair out here!

    I’m developing a test search here: https://composersedition.com/search-test/

    As you can see there are no search settings visible. I have Frontend Search Settings > General > Set the search settings to visible by default? On but the settings do not appear (as you can see above). It makes no difference whether I’m using Hovering or ‘Block or custom’ search settings position, nor if I add the Custom Settings position shortcode to the page.

    The search works and I have Generic filters included as well as some Categories and Taxonomy Terms included. I’ve also tried adjusting the CSS and JS compatibility settings, but no joy.

    Any help much appreciated.

    Regards,

    Dan Goren

    #29977
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Dan,

    The page there is very heavily cached. I strongly recommend turning off all the cache while making changes, as it will just compile/minify the assets and changes might not be apparent until it expires.
    If you clear the page, asset, minify, CDN and browser caches, it should start working.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #29982
    dangoren89
    dangoren89
    Participant

    Hi Ernest,

    Thanks for getting back to me. I have been clearing caches frequently and tried it on multiple browsers and devices (also cleared). I’ve just done so again and also put the site in development mode at Cloudflare so there really shouldn’t be anything hanging over from yesterday, but it’s still not working…

    #29983
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thanks, it now shows the search on my end, but the settings indeed does not display. I am seeing the following custom CSS in the site header:

    .asp-fss-flex {
        display: none!important;
    }

    That basically hides the settings form completely. Make sure to remove it. If I manually disable it on the browser debug window, everything works okay: https://i.imgur.com/IQkCTg4.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #29984
    dangoren89
    dangoren89
    Participant

    Oh, crikey! My Bad! Sorry to trouble you with this. Thank you for your time.

    Dan

    #29985
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    No problem 🙂

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.