Settings Dropdown Box display issues

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Settings Dropdown Box display issues

This topic contains 4 replies, has 2 voices, and was last updated by Penny Penny 3 months, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #36423
    Penny
    Penny
    Participant

    If I set the “Search settings position” to Hovering, the settings drop down box does not display, as it tries to load above the search box, rather than below. There is no room for this as the search box is at the top of the page with the header.

    If I change it to Block or custom, it does not display at all although it pushes everything down on the page slightly.

    It displayed properly i.e. below the search box, when I used the Lite version of the plugin. I have placed the Pro shortcode in the same place as where the Lite shortcode was and have made no changes to the theme in between upgrading the plugin from one version to another.

    Unfortunately, I cannot give you an URL or a log in as the site is on my local machine.

    Thanks!

    Attachments:
    You must be logged in to view attached files.
    #36436
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Unfortunately I can’t replicate this behaviour, it is very likely related to a specific configuration and the exact implementation. There are no other reports of similar issues, so there is no known problem I could suggest a solution to.

    To resolve this, I will have to see it directly. Please let me know if you deploy the site to a test/staging environment online, and I will check.

    From the screenshots it appears to me, as if the settings block was completely emtpy, and displayed with a slight offset to the top. What happens if you place the search bar somewhere in the middle of the page? How is it displayed then?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #36441
    Penny
    Penny
    Participant

    Hi Ernest

    I placed the shortcode randomly in the middle of some content, switched to the default WordPress theme and disabled every single plugin except yours and sadly still get the same thing…

    Attachments:
    You must be logged in to view attached files.
    #36443
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Are there any filters set within the settings box? It looks empty to me, it may try to calculate the position, but since it is empty, it may show on an incorrect position. Can you please try to temporarily enable these filters: https://i.imgur.com/v089nue.png

    The let me know how it looks then, in both the default “hover” and the “block layout mode”. Thank you!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #36444
    Penny
    Penny
    Participant

    Hi

    That seems to be a bit better: when set to Hovering it now goes downwards but the settings display over the text box making it impossible to type anything. When set to Block it does display below the text box, but pushes everything below it down even further, which is not an ideal solution.

    Attachments:
    You must be logged in to view attached files.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.