Several problems with Ajax Search Pro

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Several problems with Ajax Search Pro

This topic contains 2 replies, has 2 voices, and was last updated by

 
Keymaster
5 years, 5 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #9848

    Participant

    Hi,

    I just bought and installed Ajax Search Pro, and have noticed a couple of problems.

    1. First, I started getting occasionally the message “Warning! The response data is missing from the ajax request!”. I have version 4.9.5. I disabled the cache, disabled the keyword suggestions and autocomplete, and I still got the error. I even activated the custom ajax handler, but I still got the message.

    What I would do, for example, was to type one letter at a time. Then, at letter 5, for example, I would get the message, but if I clicked the search button for those same five letters, the search would succeed. Then, I could type more letters, and at random, the message would popup.

    Since the searches worked most of the time, what I did was just disable the alert in the javascript. After I did this, I’ve tried to reproduce the problem again, and I haven’t seen any more messages logged to the console (as the javascript logs the error to the console again), so I’m not sure what was going on.

    As I now have a change in the plugin, which I’d rather not have as it will be removed when the plugin is updated, I wanted to suggest creating a new option to enable or disabling these alerts, for example, to just log the errors to the console or perhaps, to a log file that would be reviewed in the admin area. But at least the option to disable the alert would help.

    As for the reason of the error, I’m not sure why I’m getting it, but since the search works most fine in most cases, except on random times, by disabling the alert the problem is not noticeable.

    2. When I add keyword exceptions, I stop getting results. I tested this with both the regular search engine and the index table. I added the list “de, a, por” and after this, I could not get any result in the search.

    3. Finally, after I added the index table, I started noticing some results were not showing up. For example, if I typed “transferencias” I would see the result “Transferencias de Inventario” (image 1). But if I typed “transferencias de”, that result would no longer show up (image 3). I had to set the min word length to 1 to get all the results, and also disable the stop words (image 3).

    Thanks,
    Arturo

    Attachments:
    You must be logged in to view attached files.
    #9850

    Participant

    These are the other two images.

    Attachments:
    You must be logged in to view attached files.
    #9861

    Hi!

    Can you please update your ticket with temporary FTP and log-in information? I’m guessing the issues might be related to a higher level caching, but I cannot investigate unless I’m able to debug through the code.

    1. It happens when the ajax request fails for some reason: termporary server outage, internal error, php fatal error. Removing the JS part will not solve the actual problem, that the ajax response is failing.

    If it’s irregular, and there is no certain search phrase causing it, then it’s definitely a server related problem, which usually goes away once the server is stable again. If it was a php error, it would be re-creatable by entering the same search phrase and getting the error message every time. If that is the case, let me know what phrase(s) are definitely causing the error, and I will be able to get to it via debugging.

    2. Make sure that the keyword exceptions are not entered into the first option on that panel, but to the second one Keyword exceptions – replace whole words only: https://i.imgur.com/f5D9TYr.png

    If you enter those words to the first one (replace anywhere) then even partial matches will be replace, therefore for example the search phrase “Transferencias de” will become “Trnsferencs” which will probably return 0 results.

    3. And are they still not showing up? If the word length is now 1 and stop words are disabled and the index is re-created it should be working fine. If not, then re-create the index after saving to make sure it’s in effect.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.