Simplify or disable results list

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Simplify or disable results list

This topic contains 3 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 2 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #37975
    lvbhb
    lvbhb
    Participant

    We’re using ASP to search a specific set of PDF’s (filtered by custom field). The indexing and basic search setup (see this ticket) works fine now.
    We like the way the ‘Live Search Results” work: a simple list of title’s, if you click one the PDF opens directly in a new tab.

    However when a visitor types <Enter> of clicks the search icon as most people are used to, the result page is less useful:

    • You get a blog-like list where you are stil 2 clicks away from opening the PDF;
    • The listed results do not open in a new tab. I did set ‘When clicking on a result, open it in a new window?’ to ON;
    • The search box disappears and there is no ‘search again’ or ‘back to search’ button

    The styling of the results page looks like that of the WordPress site search as determined by our theme (Avada). Even more: the site search now also searches the PDF contents, we don’t want that.
    Is there a way to make the results page appear as a simple list of links to the PDF documents, like the Live results and keep it completely separate from site search?

    #37977
    lvbhb
    lvbhb
    Participant

    Update: somehow I missed the ‘Logic & Behaviour’ tab. I see now that I can set ‘Override the default WordPress search results…’ to Off, so that problem is solved.
    I also see that I can set <Return>/Magnifying glass to trigger only Live search. But I still would prefer a simple results list page if possible. BTW “location: Open new tab” does not work, it opens in the same tab and unlike what people are use to from Google, Bing etc. the search box disappears. You have to go back.

    #37978
    lvbhb
    lvbhb
    Participant

    Update 2:
    After setting ‘Override the default WordPress search results…’ to Off, I get an error message from the generic WP search when I use a search term that doesn’t occur on the site:
    Warning: A non-numeric value encountered in /home/lvbhb/public_html/wp-content/themes/Avada/search.php on line 60 (and the same for lines 61 + 62)
    Example: https://www.lvbhb.nl/?s=isserniet

    #37984
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    The results page is controlled by the theme you are using. Any customization regarding it’s layout has to be made via the theme settings, or programmatically via a child theme.

    The error reported refers to the avada core template files, there is very likely something wrong in there. Try turning off Ajax Search Pro, and revisit the search results page to see if the error is still there – it should be. If so, then you may need to contact the theme support about that.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.