Some images broken / No search results

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Some images broken / No search results

This topic contains 5 replies, has 2 voices, and was last updated by

 
Participant
2 years, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #22807

    Participant

    Hi,

    I’ve bought your plugin for a few months, everything is fine until two bugs are found…

    Bug 1:
    Once the plugin has been updated to the latest version, some images are broken.

    * Only one plugin has been updated, 3rd party plugins are not related in this case.
    * When version is rollbacked to 4.15, all images exist.

    Bug 2:
    One of the search form has been duplicated – No matter any words I typed, no search results can be shown.

    Only 2 things I have changed:
    – Taxonomy in the Grouping
    – Checkbox values in Custom Fields
    * Other settings remains unchanged (eg. Same source, same logic, same post meta in custom field…)
    * This issue is still happens in the latest version.

    By observation and test, if data is filtered by ticking the checkbox value of custom field (metadata: info_company) and it shows no results, one possible way to solve the problem is to use grouping to filter the data. (Yet, other results exists for grouping). On the other hand, when the data is filtered by grouping, but no result can be found, the way to solve the issue is to use checkbox function to filter the data. That’s the way I temporarily fixing the problem. However, I’d like to unify the search form for the same filter function.

    Please help and fix.
    Thank you.

    PS. Due to the website is a local site, feel free to contact me if the information provided is not sufficient for the issue.

    Thanks,
    Kappa

    Attachments:
    You must be logged in to view attached files.
    #22815

    Hi!

    1. What types of results are the images missing on? Are these posts/products or any other post type, or maybe attachments or categories? Let me know, I will check the source for differences.

    2. I am not sure if I am able to tell, but it I am almost certain it is the custom field filters, if nothing else differs. Try removing the custom field filter to see if it makes any difference. If so, then either the filter values or something around there is the problem.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #22822

    Participant

    Thank you so much for the prompt reply!

    1. Those are the images of custom field. For details, please take a look at pdf.

    2. Thanks, the search form works after the custom field filter has been removed. However, is it possible to keep using custom field filter?

    PS. Backup file (.wpress) can be shared in zip format if necessary.

    Attachments:
    You must be logged in to view attached files.
    #22842

    Hi!

    1. Okay, I see what you mean now. That is the elementor page, unrelated to the search. The plugin image options can only affect the images within the live results list (image 1). The page images are printed by elementor. You might have to adjust that somewhere in that plugin options.

    2. Well I am sure it is possible, but then the filter needs to be corrected. Either some of the filter values are incorrect, or there is something wrong with the configuration. Without actually lookingat it I am not able to tell though.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #22878

    Participant

    Hi! Thank you very much! 😀

    1. Awwwww I couldn’t find any option about this adjustment in that plugin. Perhaps I should contact the the developer about this issue.

    2. I’m currently checking for the filter values. Will reply you after testing.

    Best regards,
    Kappa

    #22909

    Participant

    Hi!

    1. I’m temporarily using old version to prevent missing images.

    2. All problem solved 😀

    Thanks,
    Kappa

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.