Trying to match seach results

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Trying to match seach results

This topic contains 1 reply, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 year, 10 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #30497
    GeorgiaG06
    GeorgiaG06
    Participant

    I am trying to match results for my site-wide searches in the header or footer to my area search. For instance, if you search for conductor in the header it is not the same result as you get from a search on this page https://www.ilcenacolosf.org/la-cultura-italiana/ where there is a section search under the header image to the right. On this page, I get 3 conductors – from that section and as expected. If I search from the top bar or footer I get 3 results from other areas of the site but not the three conductors.

    I have added as much information as I can to the top bar/footer search but still can not get the results. It is much more limited. Can you see what I have done wrong?

    Thank you for your help. Georgia

    #30503
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Georgia,

    Thank you for the details, it helped a lot.

    The main difference on the two search bars was, that the one on the linked page is using the Regular engine, while the other one the Index table engine.
    I found, that the the word “conductor” was actually within a custom field, which was not indexed, hence the results were missing from the header search. I selected the following fields in the index table options panel, and created a new index: https://i.imgur.com/Yv5YiNS.png
    That seems to have resolved it. Now I am getting those results as well: https://i.imgur.com/5aa9Nud.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.