When a filter is active jQuery broke

Home Forums Product Support Forums Ajax Search Pro for WordPress Support When a filter is active jQuery broke

This topic contains 1 reply, has 2 voices, and was last updated by

 
Keymaster
1 year, 9 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #26905

    Participant

    The site is made with elementor, I created a search form for this page:

    https://demo.matteomanzini.com/vfc/production-guide/attori/

    but when I do a search it seems that there is “interference” with jQuery.

    I thought it was a Live Search problem so I disabled it but the problem still occurs

    The things I’ve noticed so far when I filter a search:

    1) In the menu the arrow symbol indicating the sub-menus is duplicated each time the search is filtered
    2) In mobile the hamburger menu stops opening
    3) If I use an element that provides interaction (for example a dropdown now commutator) it stops working or opens and closes immediately. (I added a couple of these items to the page as an example)

    I have already tried to disable other plugins, put the theme back to default but the problem continues to arise.
    I don’t see any errors in the server log

    • This topic was modified 1 year, 9 months ago by  MatteoMNZ83.
    Attachments:
    You must be logged in to view attached files.
    #26918

    Hi,

    Thank you very much for the details. This was actually a tough one, but I found and fixed the issue via FTP access.
    The issue was related to a re-initialization method with Elementor widgets, the same issue is described here.

    I will make sure to further test, and include this fix in the upcoming release, so you don’t have to worry about it anymore.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.