WP search is displaying sometimes!

Home Forums Product Support Forums Ajax Search Pro for WordPress Support WP search is displaying sometimes!

This topic contains 3 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 8 months, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #34401
    Preet
    Preet
    Participant

    Quite a lot of the time, logged-out pages show the WP search field instead of the ASP field, which has become quite a problem.

    I have two ASP instances, which display conditionally on role and logged in status. The Woocommerce store has products that are protected by Woocommerce memberships, and this approach allows me to provide useful search in the context of what will be available to the user. So I have a product taxonomy for products that are hidden that is excluded from search too. The only visible difference in the instances is that the reduced set placeholder says: “Search here naturally” and the full set placeholder says “Search all our products naturally”.

    The search field is in a Astra Pro Custom layout which inserts itself on all pages. Within that, Elementor formats the background and both instance shortcode widgets are loaded in the page, with the reduced set instance displayed by default, and hidden (by UAE Display Conditions) if the user has one of three roles. In that situation, the other instance is displayed.

    We have Cloudflare Pro, and clearing caches seems to help. We also have redis object and page caching on server. But I’m struggling to understand what is stopping the ASP field from displaying in some pages sometimes, and why the native search is appearing. Can you help?

    It’s a bit tricky to give access to the site as it is fill of customer data and we have GDPR.

    Many thanks,

    • This topic was modified 8 months, 2 weeks ago by Preet Preet.
    Attachments:
    You must be logged in to view attached files.
    #34410
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Can you please check this option and make sure it is turned off: https://i.imgur.com/7Bau089.png
    There might be a cache hit/miss for a specific browser agent and the plugin may display the default search bar instead of the shortcode. After turning that off and clearing the cache the issue should go away.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #34411
    Preet
    Preet
    Participant

    Hi Ernest,

    Thank you! I do most of my logged out testing in Safari 14, and that is also our customers’ main browser.

    Hopefully the problem will not come back.

    Best wishes,

    • This reply was modified 8 months, 2 weeks ago by Preet Preet.
    #34412
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.