400 error

This topic contains 13 replies, has 2 voices, and was last updated by

 
Participant
11 hours, 7 minutes ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #24863

    Participant

    Hello,

    PoemAnalysis.com has the ajax search pro in the header (I think) – but it throws a 400 error everytime anything is searched? How do I fix this?

    Many thanks,

    Will

    #24864

    Participant

    Hello,

    This appears to be fixed now, although the box is meant to be grey and green but is currently red and not updating?

    #24865

    Participant

    Also, this appears every so often?

    Attachments:
    You must be logged in to view attached files.
    #24867

    Participant

    Fixed!

    #24868

    Participant

    But the error is still appearing (style if fixed) – why is this popping up and how to fix?

    #24872

    Hi,

    The error message means, that something is tempering with the request, and it is not returned correctly, or is completely missing.
    It can be caused by multiple things:
    – Temporary server outage (very likely)
    – WordPress configuration reltated issue, such as the site is accessed via http://www.yoursite.com, but the non www version is the correct. Another usual issue is that the site can be accessed via http and https protocols, but only one of them is correct.
    – .htaccess file has an incorrect mod_rewrite rule or flag
    – another plugin or a custom code is changing the request

    Unfortunately in most cases the issue is unrelated to the plugin. I can take a look if you want to, to see what is returned. For that, please add temporary FTP and back-end details to access your server. Thank you!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #24892

    Participant

    Hello,

    It seems the issue has been fixed, so that’s good! Although, there is a new issue…

    With regards to the logic, it seems to work well but if you go on poemanalysis.com and search for ‘the road not taken’, the article ‘The Road Not Taken by Robert Frost’ does exist, the auto fill appears with this, but the results do not show the article – why is this the case and how can I fix this?

    Many thanks,

    Will

    #24898

    Hi,

    The result is matched, but not in the first 4 matches. With the default configuration it should definitely show up as the first one.
    Can you please add temporary FTP and back-end details? I would like to check the configuration, as well as perform a basic debugging on the query to see if everything is running okay.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #24907

    Participant

    Hi there,
    I would but like to confirm if the logic is correct at just ‘AND’, or should that be something else incombination with something else?
    Kind regards,

    Will

    #24912

    Hi Will,

    Yes, that logic is fine. In fact, in this case it would not matter, as it should get the highest possible relevance either way.
    There are many things that could affect the results, like ordering, post type ordering, relevance values, priorities or group priorities etc.. Running a basic debug on the code will reveal the issue in no time.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #24931

    Participant

    Hello,
    Okay, I’ve provided details for login – are you able to look into the plugin on the website and find the solution for this issue?
    Many thanks,
    Will

    #24932

    Participant
    You cannot access this content.
    #24935
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #24959

    Participant

    Hello,
    Please try again and should be okay.
    Will

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.